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Bluebeam prompting a Subscription Expire Notice

Modified on: Fri, Apr 25 2025 1:51 PM
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BTech Alerts & Notifications - Check this page for the latest information on emergencies and system outages. All times are Pacific.


Bluebeam


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  • Thank you for troubleshooting with our self-service tools!
  • If, at anytime, any assistance is needed:


Problem

  • Bluebeam prompt:
    • Your subscription will expire in X days. Save your work and renew your subscription to keep using Bluebeam.

Cause

  • The license for Bluebeam was renewed, but not all Bluebeam applications took the updated subscription information.


Estimated Troubleshooting Time

  • 10-15 minutes.
    • *Download and installation time may vary.


Solution

  1. Determine the version of Bluebeam on your device:
    1. Within Bluebeam, click Revu
    2. Click About
    3. Note the Version Number (21.0.3 or 21.4 or higher)

  2. Update or refresh based on the Version:
    • For Version 21.0.3, update Bluebeam
    • For Version 21.4 or higher, refresh your Bluebeam Account


Refresh your Bluebeam Account (for version 21.4 or higher)

  1. Within Bluebeam, click on your email address (in the upper right hand corner)
  2. Click the Refresh button
  3. Close Bluebeam
  4. Launch Bluebeam
  5. The Subscription expiration message should no longer appear.
    • If the message does reappear, open a ticket (if you don't already have one open) if you do have a ticket coordinate with your support technician for next steps.


Update Bluebeam (for version 21.0.3)

  1. Navigate to the Software Center


  2. Search for Bluebeam version 21.5


  3. Select "Bluebeam Revu (MSI-x64) 21.5.0"

  4. Click Install


  5. If you are having issues with the installation, please close all processes that aren't the Software Center and attempt again, you may need to click "Install" multiple times
    • If issues persist, please submit a ticket (if you don't already have one) or coordinate with your support technician for next steps

  6. Update Complete
    • Verify version per the process (see above).
    • If your Bluebeam version is now 21.4 or higher, you may have to refresh your Bluebeam Account.



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